Help Center
Choose product document...
Veeam Backup for Microsoft Office 365
User Guide

System Requirements

The following system requirements must be met for Veeam Backup for Microsoft Office 365 to operate normally.

Supported Microsoft Exchange Organizations

Requirement

Specification

Comments

Exchange Organization

Microsoft Office 365 Exchange Online

For system requirements and limitations for Office 365, see this Microsoft article.

Microsoft Exchange 2016 or 2013 (on-premises)

For limitations on backup and restore of mail items, see the Considerations and Limitations section.

System Requirements Note:

Throttling policies for Exchange Online cannot be managed through the Office 365 administrative interface, you need to contact Microsoft technical support to make changes.

Veeam Backup for Microsoft Office 365 Server

Specification

Requirement

Hardware

CPU: any modern multi-core x64 processor, 4 cores minimum.

Memory: 8 GB RAM minimum. Additional RAM and CPU resources improve backup, restore and search performance.

Disk Space: 500 MB for product installation and additional free disk space for archives, depending on the amount of mailboxes, their change rate and the retention policy.

OS

Only 64-bit version of the following operating systems are supported:

  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2 SP1
  • Microsoft Windows 10
  • Microsoft Windows 8.x
  • Microsoft Windows 7 SP1

Software

 

  • Microsoft .NET Framework 4.5.2 or later.
  • Mail restore requires Veeam Explorer for Microsoft Exchange 9.6.
  • To use PowerShell cmdlets for backup and/or restore, Windows PowerShell 2.0 or higher is required. When using Windows 2012 or 2012R2, Windows Powershell 2.0 Engine must be installed regardless of the current PowerShell version.
  • For more information on Microsoft Office 365 system requirements and limitations, see this Microsoft article.
  • Mail backup is supported for Microsoft Exchange 2016 or 2013.
  • For more information on Update for Universal C Runtime (CRT) in Windows, see this Microsoft article.
  • (optional) Veeam Backup & Replication or Veeam Agent for Microsoft Windows for management server backup.  Application-aware processing of Veeam Backup for Microsoft Office 365 server will be supported by Veeam Backup & Replication 9.5 Update 3 and later, and Veeam Agent for Windows 2.0 and later.
  • (optional) If you plan to export folders and items as Personal Folder Files (.PST), it is necessary to have a 64-bit version of Microsoft Outlook 2016, Microsoft Outlook 2013 or Microsoft Outlook 2010 installed on the machine where Veeam Explorer runs.

System Requirements Important!

  • When you install Veeam Explorer for Microsoft Exchange and Veeam Backup for Microsoft Office 365 on different servers, the OS version on computers with Veeam Explorers must be the same or higher than the OS version on a computer with Veeam Backup for Microsoft Office 365.
  • For Microsoft Outlook 2016 the preliminary releases, like Insider releases, or releases provided through Monthly Channel Updates are not supported; Veeam supports only RTM/GA versions of this product. For more information, see this Microsoft article.

Veeam Explorer for Microsoft Exchange

To learn more about system requirements for Veeam Explorer for Microsoft Exchange, see the Veeam Explorer for Microsoft Exchange user guide.

Backup Proxy

Backup proxy server can be a physical or a virtual machine with Microsoft Windows OS that meets the requirements below.

Specification

Requirement

Hardware

CPU: any modern x64 processor, 4 cores minimum.

Memory: 8 GB RAM minimum. Additional RAM and CPU resources improve backup, restore and search performance.

OS

Only 64-bit version of the following operating systems are supported:

  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2 SP1
  • Microsoft Windows 10
  • Microsoft Windows 8.x
  • Microsoft Windows 7 SP1

Proxy servers can be deployed on the following core editions:

  • Microsoft Windows Server 2016 LTSC, 1709
  • Microsoft Windows Server 2012 R2

Other

Microsoft .NET Framework 4.5.2 or later

(optional) Windows C Runtime and Update (UCRT) in Windows. For more information, see this Microsoft article.

System Requirements Important!

Backup proxy servers and the Veeam Backup for Microsoft Office 365 server must be deployed within the same or trusted domain.

Backup Target

To store your backups you can use the following disk-based storage systems:

  • SMB 3.0 share (experimental support). The backup server account must have the corresponding permissions on a network share. For more information, see Required Permissions.

Storage volumes that host archive repository must be formatted with NTFS or ReFS.

System Requirements Important!

Consider that Microsoft Windows 7 SP1 and Microsoft Windows 2008 R2 SP1 do not support the SMB 3.0 share as a storage system. To use the SMB 3.0 share as a storage system, make sure you are using Microsoft Windows 8 or Microsoft Windows 2012 or higher.

Veeam Large Logo

User Guide

RESTful API Reference

PowerShell Reference