Veeam Home | Support | Downloads
Veeam Backup & Replication Plug-in 1.1 for LabTech

Veeam Help Center  > User Guide >  Prerequisites > System Requirements

System Requirements

Previous page Next page Print this Topic

Table of contents

To install and use the plug-in, make sure that your LabTech IT automation system meets the necessary system requirements.

LabTech Server

The machine where you want to install the Veeam Backup & Replication Plug-in must meet the following requirements:

Specification

Requirement

LabTech RMM

LabTech 11

LabTech 10.5

OS

Only 64-bit versions of the following operating systems are supported:

Microsoft Windows Server 2012 R2

Microsoft Windows Server 2012

Microsoft Windows Server 2008 R2 SP1

Microsoft Windows Server 2008 SP2

Software

LabTech Server (for software and hardware requirements, refer to LabTech Installation Prerequisites).

Microsoft .NET Framework 4 or later

Microsoft PowerShell 2.0 or later

Backup Manager Plug-in

The Veeam Backup & Replication Plug-in integrates with LabTech Backup Manager to help you quickly identify issues with backup and replication jobs.

For details on Backup Manager installation and configuration, refer to LabTech Backup Manager documentation.

Veeam Backup Servers

Every managed machine that runs Veeam Backup & Replication or Veeam Backup Enterprise Manager must have the following software installed:

LabTech Agent*

Microsoft PowerShell 2.0 or later

Veeam Backup & Replication 8.0 or 9.0 (Standard, Enterprise or Enterprise Plus Edition)

 

It is recommended that you enable automatic updates of Veeam Backup & Replication licenses on Veeam backup servers and Veeam Backup Enterprise Manager servers. For details on enabling automatic license update, see Appendix B. Automatic License Update.

Virtual Machines

Every managed VMware and Hyper-V virtual machine** must have LabTech Agent*, and either VMware Tools or Hyper-V integration services installed.

 

*For software and hardware requirements to machines running LabTech agents, refer to LabTech Agent Deployment Requirements.

**For virtualization platforms and versions supported by Veeam Backup & Replication, refer to Veeam Backup & Replication Help Center.

Table of contents