Upgrading Plug-In

If you want to upgrade your AWS Plug-in for Veeam Backup & Replication to a new version 10.0.3.825, you do not have to uninstall the previous plug-in version. You can download the new version and install it as described in section Installing Plug-In. During the installation process, the plug-in will detect the previous version and upgrade it.

After you upgrade AWS Plug-in for Veeam Backup & Replication, you must also upgrade your appliances in the Veeam Backup & Replication console. For more information on how to upgrade appliances, see Upgrading Appliances.

Note

Mind the following:

  • Before installing AWS Plug-in for Veeam Backup & Replication, you must first stop all policies and disable all jobs, and then you must close the Veeam Backup & Replication console.
  • If a Veeam Backup for AWS appliance is already added to the Veeam Backup & Replication infrastructure, and if the version of Veeam Updater is 2.0.0.499 or later, you will not be able to upgrade Veeam Backup for AWS to version 3.0 in the Veeam Updater UI. Instead, upgrade Veeam Backup for AWS in the Veeam Backup & Replication console as described in the Upgrading Appliance section.
  • When you upgrade AWS Plug-in for Veeam Backup & Replication, the plug-in checks the permissions of the Default Backup Restore IAM role of the AWS account and grants all the permissions required to use new features that come with AWS Plug-in for Veeam Backup & Replication version 10.0.3.825 — restore of the VPC configurations, restore of Amazon RDS instances, and so on. This AWS account will be also granted all permissions required to perform operations available in AWS Plug-in for Veeam Backup & Replication version 10.0.1.661.
I want to report a typo

There is a misspelling right here:

 

I want to let the Veeam Documentation Team know about that.