Error Retrieving User Profile

Issue

While trying to access Veeam Data Cloud for Microsoft 365, you get an error and cannot continue.

Summary

When you log in to Veeam Data Cloud for Microsoft 365, you may see the following error:

Veeam Data Cloud encountered an error retrieving the user profile. Please try again or contact support if it persists.

Cause

Your network configuration is blocking the access to Veeam Data Cloud for Microsoft 365.

Resolution

Add the following URLs to your firewall or allowlist:

  • vdc-m365-api-[env].veeamdatacloud.com — API connection used for initial authentication and then for backup and restore.
  • vdc-m365-public-[env].veeamdatacloud.com — API connection used by Veeam Data Cloud. It is also used for reporting, if enabled.
  • vdc-cloud-api-[env].veeamdatacloud.com — API connection used for initial authentication and then for backup and restore.

Where [env], use your Veeam Data Cloud region: EMEA, AMER, APJ.

Help And Support

If you have followed the listed steps and the issue recurs in the next backup cycle, or you need help with performing these changes, contact Veeam Customer Support.