Outlook: Failed To Find Group Owner Account
Issue
While backing up a mailbox, the job is completed successfully, but your Veeam Data Cloud backup logs say that the job has completed with a warning: Failed to find group owner account.
Summary
When you review your completed Veeam Data Cloud backup that includes Microsoft Exchange items, you may see the following warning message in the backup session logs:
Warning Processing mailbox <Name> completed with warning: Failed to find group owner account |
Cause
Veeam Data Cloud is unable to impersonate Microsoft 365 groups (mail-enabled and security groups) that do not have an owner assigned. This is a known Veeam and Microsoft issue.
Resolution
Assign an owner to each of the Microsoft 365 groups that you want to back up. For information on how to do this, see this Microsoft article.
Help And Support
If you have followed the steps outlined above, and the issue recurs in the next backup cycle, or you need help with performing these changes, you can contact Veeam Customer Support.
References
For information on how to check your backup session logs, see Viewing Backup Logs.