SharePoint: Failed To Request File Versions For Item

Issue

While backing up SharePoint sites, your Veeam Data Cloud backup logs say that the backup policy session has completed with a warning: Failed to request file versions for item.

Summary

When checking your Veeam Data Cloud for Microsoft 365 backup session logs, you may see the following warning:

Warning

Processing site <Name> () finished with warning: Failed to request file versions for item/ sites/ file name.aspx from list Pages (listID: <list ID>, itemID: <item ID>), exception: User cannot be found.)

Cause

The SharePoint site has been checked out for modification by a user.

If you also get the User cannot be found exception, the user no longer exists in the directory.

Resolution

The user should either discard or save their modifications on the SharePoint site.

If you also get the User cannot be found exception, check the user profile in the SharePoint admin center. For more information, see this Microsoft article.

Help And Support

If you have followed the steps outlined above, and the issue recurs in the next backup cycle, or you need help with performing these changes, you can contact Veeam Customer Support.

References

For information on how to check your backup session logs, see Viewing Backup Logs.