Upgrading Product

In this article

    Veeam Agent for Oracle Solaris supports upgrade from version 2.0 to version 2.1. To upgrade the product, install the new Veeam Agent for Oracle Solaris package in the regular way. To learn more, see Installing Veeam Agent for Oracle Solaris.

    During the upgrade process, configuration and backup files that were created with the previous version of Veeam Agent are not impacted in any way.

    Upgrading Product from Version 1.0

    If a machine where you plan to install Veeam Agent for Oracle Solaris 2.1 runs version 1.0 of the product, to upgrade the product, complete the following steps:

    1. Copy Veeam Agent for Oracle Solaris 1.0 configuration files from the product installation directory to a separate directory on the Veeam Agent machine or to a network shared folder. These configuration files are required to restore data from backups created with Veeam Agent for Oracle Solaris 1.0. The following files are required:
    • /etc/veeam/devices.ini

    This file contains information about backup locations configured in Veeam Agent for Oracle Solaris 1.0.

    • /etc/veeam/ubax.ini

    This file contains information about the default backup location specified in Veeam Agent for Oracle Solaris 1.0.

    • /etc/veeam/scripts/veeam.scp (or custom script that you specified in Veeam Agent for Oracle Solaris 1.0 backup settings)

    This file is required to restore data from a Veeam Agent for Oracle Solaris 1.0 full backup using a restore script.

    • /etc/veeam/media/*.lml

    Media library (.lml) files are required to restore data from a Veeam Agent for Oracle Solaris 1.0 full backup using a media library entry.

     

    Upgrading Veeam Agent for IBM AIXOracle SolarisImportant!

    Make sure you have copied configuration files before you proceed to the step 2. Otherwise, when you uninstall Veeam Agent for Oracle Solaris 1.0, these files will be deleted along with the product.

    1. Uninstall Veeam Agent for Oracle Solaris 1.0. To do this, use the following command:

     

    pkgrm VeeamAgent

    During the uninstallation process, backup files created with Veeam Agent for Oracle Solaris 1.0 are not impacted in any way.

    1. Install Veeam Agent for Oracle Solaris 2.1. For details, see Installing Veeam Agent for Oracle Solaris.
    I want to report a typo

    There is a misspelling right here:

     

    I want to let the Veeam Documentation Team know about that.