Product Versions in Veeam Cloud Connect Infrastructure

In this article

    SP and tenants can run different versions of Veeam Backup & Replication on their Veeam backup servers. Veeam products on the SP and tenant side must meet the following requirements:

    • Veeam Backup & Replication versions must support the Veeam Cloud Connect functionality.
    • The SP Veeam backup server must run the same or later version of Veeam Backup & Replication than the tenant Veeam backup server.

    This applies to major product versions. Within Veeam Backup & Replication version 11, the SP and tenant can use any product build. It is recommended, however, that the SP and tenant install latest hotfixes and updates on the backup server.

    • Veeam Backup & Replication 11 running on the SP backup server is compatible with the following versions of Veeam products running on the tenant side:
    • Veeam Backup & Replication 9.5 Update 4b (build 9.5.4.2866) and later
    • Veeam Agent for Microsoft Windows 4.0 (build 4.0.0.1811) and later
    • Veeam Agent for Linux 4.0 (build 4.0.0.1961) and later
    • Veeam Agent for Mac 1.0 (build 1.0.0.713) and later

    If the SP or tenant plan to upgrade Veeam Backup & Replication, the upgrade process must start on the SP side. The upgrade process should be performed in the following way:

    1. The SP upgrades Veeam Backup & Replication on the SP backup server. The upgrade procedure does not differ from a regular one. To learn more, see the Upgrading to Veeam Backup & Replication 11 section in the Veeam Backup & Replication User Guide.
    2. After Veeam Backup & Replication on the SP side is upgraded, the tenant can perform the same upgrade procedure on the tenant backup server.

    Tenants who run earlier versions of Veeam Backup & Replication can continue using cloud resources provided to them by the SP who has upgraded Veeam Backup & Replication. However, some Veeam Cloud Connect functionality introduced in the current version of Veeam Backup & Replication may be not available to these tenants. For example, tenants who run Veeam Backup & Replication 9.5 Update 4 cannot create backups on an NFS share that is used as a backup repository and exposed as a cloud repository.