System Requirements

Make sure that components in the plug-in management infrastructure meet system requirements listed in this section.

Veeam Backup Server

To learn about system requirements for the Veeam backup server and other Veeam Backup & Replication components, see the System Requirements section in the Veeam Backup & Replication User Guide.

Computer with Veeam Plug-in for Oracle RMAN

A computer with databases you want to protect using Veeam Plug-in for Oracle RMAN must meet the following requirements:

Specification

Requirement

OS

Veeam Plug-in for Oracle RMAN is supported for the following Microsoft Windows versions:

  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012/2012 R2
  • Microsoft Windows Server 2016
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2022

Veeam Plug-in for Oracle RMAN is supported for the following Linux distributions:

  • SUSE Linux Enterprise Server 11, 12, 15 (x86 and x86_64)
  • Red Hat Enterprise Linux 6.4 – 9.x (x86 and x86_64)
  • Oracle Linux 6.2 (x86 and x86_64)
  • Oracle Linux 6.4 – 9.x (x86 and x86_64)
  • CentOS 6.4 – 8.x (x86 and x86_64): For non-production environments, as it is not officially supported by Oracle for their databases.

Note:

Veeam Plug-in for Oracle RMAN in managed operation mode is not supported for Oracle Solaris and IBM AIX.

Software

[For Microsoft Windows computers] Microsoft .NET Framework 4.6 is included in the Veeam Plug-in for Oracle RMAN Redistributable. During the deployment process, Veeam Backup & Replication checks whether Microsoft .NET Framework 4.6 is available on the target computer. If Microsoft .NET Framework 4.6 is missing, Veeam Backup & Replication will install missing software automatically.

Oracle database

Veeam Plug-in for Oracle RMAN supports the following Oracle database versions:

  • 11gR2
  • 12c
  • 18c
  • 19c
  • 21c: Standard and Enterprise Edition

The Oracle database configuration must meet the following requirements:

  • Oracle database must be in the OPEN state.
  • Oracle database must work in the ARCHIVELOG mode.

Notes:

 

  • Oracle Express Edition (XE) is not supported.
  • Oracle databases residing in containerized environments are not supported.

Oracle RMAN features

The following Oracle RMAN features are supported:

  • Veeam Plug-in for Oracle RMAN will be registered as an SBT_TAPE device. All Oracle RMAN functionality that is supported with the SBT_TAPE device type will work. For example, Automatic Storage Management (Oracle ASM) and Container DBs (CDBs).
  • Veeam Plug-in for Oracle RMAN supports Oracle Real Application Clusters (Oracle RAC). Other cluster databases are not supported.

Note:

[For Microsoft Windows computers] Configurations with different versions of Oracle homes deployed on the same server are not supported.

Computer with Veeam Plug-in for SAP HANA

A computer with databases you want to protect using Veeam Plug-in for SAP HANA must meet the following requirements:

Specification

Requirement

OS

Veeam Plug-in for SAP HANA supports 64-bit versions of the following distributions:

  • SLES 15: GA, SP1, SP2, SP3, SP4, SP5
  • SLES for SAP Applications 15: GA, SP1, SP2, SP3, SP4, SP5
  • SLES 12: GA, SP1, SP2, SP3, SP4, SP5
  • SLES for SAP Applications 12: GA, SP1, SP2, SP3, SP4, SP5
  • RHEL for SAP HANA 9: 9.0, 9.2
  • RHEL for SAP Solutions 9: 9.0, 9.2
  • RHEL for SAP Solutions 8: 8.0, 8.1, 8.2, 8.4, 8.6, 8.8
  • RHEL for SAP Solutions 7: 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.9

SAP HANA database

Veeam Plug-in for SAP HANA supports SAP HANA 2.0: SPS 02, SPS 03, SPS 04, SPS 05, SPS 06, SPS 07 (only with Backint version 1.0). Express Edition is not supported.

SAP HANA 1.0 is not supported.

Note:

To check whether an OS version is compatible with the SAP HANA release you want to use, see the SAP HANA Administration Guide.

Computer with Veeam Plug-in for SAP on Oracle

A computer with databases you want to protect using Veeam Plug-in for SAP on Oracle must meet the following requirements:

Specification

Requirement

OS

The following operating systems are supported:

  • SUSE Linux Enterprise Server 11, 12, 15 (x86_64)
  • Red Hat Enterprise Linux for SAP Applications 6, 7, 8 (x86_64)

BR*Tools

BR*Tools 7.20 Patch 42 or later.

Oracle database

Oracle Database 11gR2, 12c, 18c, 19c: Standard and Enterprise Edition.

Oracle Express Edition (XE) is not supported.

Network

Veeam Plug-in must be able to establish a direct IP connection to the Veeam Backup & Replication server. Thus, Veeam Plug-in cannot work with the Veeam Backup & Replication server that is located behind the NAT gateway.