Missing Alerts in the OpsMgr Console

Symptoms

Alerts on vCenter events or performance status are not received in OpsMgr, when such alerts were expected (for example, Alarms were triggered in vCenter, but no matching/related alerts appeared in OpsMgr).

Causes

  • There may be a connection or configuration problem between VE Service/Collectors and the VMware systems. First work through the checks described in previous troubleshooting steps above (Veeam Virtualization Extensions UI dashboard, perform Test Connection and so on).

If all connections and configuration are optimal, then check the following:

  • The relevant Rules/Monitors may be disabled in OpsMgr — either in the default configuration or by override.
  • The relevant Rules/Monitors may be enabled, but the threshold or response differs from the expected or default vCenter value. (this may be by design, to reduce unwanted alerts and retain operational relevance in the OpsMgr console). For example note that some vCenter Alarms may trigger a state-change in OpsMgr, but do not (by default) generate an Alert.

Solution

Review the available rules and monitors for VMware events and performance counters in the Veeam MP for VMware Reference.

This reference document set includes:

  • All performance collection rules
  • All event (alert-generating) rules
  • All performance and event based Monitors
  • All out-of-box configuration for overrides, enable/disable, and so on.

If the required rule/monitor is enabled and running, but does not seem to be firing as expected, then there may be a break in the data connection chain from vCenter to Collector to OpsMgr. Review the steps for Troubleshooting Event and Performance Data Delivery.