Veeam Components Not Visible in OpsMgr
Symptoms
The Collector server and VE Service do not appear in the Veeam for VMware > Veeam Collectors views.
Causes
- The discovery has not yet completed. As per Microsoft Best Practice, the initial discovery interval for Collector and Extensions Service is 4 hours.
- OpsMgr Agent Action Account does not have permissions required to read the registry and discover the Veeam MP for VMware applications.
- Communication problems between OpsMgr agent and OpsMgr server.
Solutions
- Wait for discovery to complete; alternatively a restart of the OpsMgr agent (System Center Management service) on the Collector / Veeam Virtualization Extensions server can initiate discovery.
- Check the permissions assigned to the OpsMgr Agent Action Account. It is recommended that an account with full administrative access to the local server.
- In the OpsMgr console, open the Agent Managed view, find the server hosting the Collector and VE Service, and check if the OpsMgr Agent has been deployed to that server and if it is reporting back with Green status to the OpsMgr server.