OneDrive: OneDrive Was Not Found
Issue
While backing up OneDrive items, the backup policy is completed successfully, but your Veeam Data Cloud for Microsoft 365 backup session logs say that the backup policy has completed with a warning: OneDrive was not found.
Summary
When checking your Veeam Data Cloud for Microsoft 365 backup session logs, you may see the following warning:
Warning Processing OneDrive <Name> completed with warning: OneDrive was not found (ID: <ID>, name: <Name>) |
Cause
Veeam attempts to process Exchange, OneDrive, SharePoint and Teams for each user. This particular warning lets you know that the end-user Microsoft license does not include a OneDrive account.
Resolution
You can edit backup policies to exclude certain items from backup. For information on how to do this, see Editing Flex Backup Policies. This is optional: the warning will have no effect on your backups, and you can safely ignore it.
Help And Support
If you have followed the steps outlined above, and the issue recurs in the next backup cycle, or you need help with performing these changes, you can contact Veeam Customer Support.
References
For information on how to check your backup session logs, see Viewing Backup Logs.