System Requirements

When you plan to install AWS Plug-in for Veeam Backup & Replication, consider the following hardware and software requirements.

Backup Server

The machine where AWS Plug-in for Veeam Backup & Replication will run must meet system requirements described in the Veeam Backup & Replication User Guide, section System Requirements. Additionally, the following software must be installed:

  • Microsoft .NET Core Runtime 6.0.24
  • Microsoft ASP.NET Core Shared Framework 6.0.24

AWS Services

The backup appliance and worker instances must have outbound internet access to a number of AWS services. For the list of services, see AWS Services.

Web Browsers

Internet Explorer is not supported. To access Veeam Backup for AWS, use Microsoft Edge (latest version), Mozilla Firefox (latest version) or Google Chrome (latest version).

Veeam Backup & Replication

AWS Plug-in for Veeam Backup & Replication version 12.7.0 supports integration with Veeam Backup & Replication version 12.1.

Veeam Backup for AWS

AWS Plug-in for Veeam Backup & Replication version 12.7.0 supports integration with Veeam Backup for AWS version 7.x.

Version Compatibility

The following table lists compatible versions of Veeam Backup & Replication, AWS Plug-in for Veeam Backup & Replication and Veeam Backup for AWS.

Veeam Backup & Replication Build

AWS Plug-in for Veeam Backup & Replication Version

Veeam Backup for AWS Build

Backup Appliance OS Version

12.1.0.2131

12.7.0.1255

7.0.0, 7.0.1

Ubuntu 22.04 LTS

12.0.0.1420

12.2.6.5

6.1.0, 6.1.1, 6.1.2

12.1.6.93

12.0.6.956

6.0.0, 6.0.1, 6.0.2

Ubuntu 18.04 LTS

11.0.1.1261
including all cumulative patches starting from P20211211 (CP3)

11.0.5.553

5.0.0, 5.1.0, 5.1.1

11.0.1.1261
including all cumulative patches prior to P20211211 (CP3)

11.0.4.305

4.0.0, 4.1.0, 4.1.1

11.0.0.837

11.0.3.1132

3.0.0, 3.1.0, 3.1.1

10.0.1.4854

10.0.3.825

3.0.0, 3.1.0, 3.1.1

10.0.1.661

2.0.0, 2.0.1