Veeam Data Movers

In this article

    Veeam Data Mover performs data processing tasks on behalf of Veeam Backup & Replication, such as retrieving source machine data, performing data deduplication and compression, and storing backed-up data on the target storage.

    For Microsoft Windows servers, Veeam Data Movers are persistent, that is, Veeam Data Mover is uploaded and installed on a server only once. Veeam Backup & Replication automatically installs Veeam Data Mover when you add a Microsoft Windows server to the backup infrastructure.

    For Linux servers, Veeam Data Movers can be persistent or non-persistent. Non-persistent Veeam Data Mover is uploaded and removed each time Veeam Backup & Replication addresses a server.

    For Veeam Data Mover to be persistent, you must specify an account with root or equivalent to root permissions when adding a Linux server. Persistent Veeam Data Movers are required for the following backup infrastructure components:

    For other backup infrastructure components based on Linux servers, Veeam Data Movers can be persistent or non-persistent. If you do not want to provide root or equivalent to root permissions, specify an account with non-root permissions. In this case, Veeam Data Movers will be non-persistent. Veeam Backup & Replication will upload and start Veeam Data Movers through the SSH connection when Veeam Backup & Replication addresses the server.

    Note

    In Veeam Backup & Replication version 11a, persistent Veeam Data Movers are required for Linux servers with the backup proxy role assigned. When you upgrade to Veeam Backup & Replication version 11a, Veeam Backup & Replication automatically updates all Linux backup proxies and installs Veeam Data Movers on them. Veeam Backup & Replication does not automatically update Linux servers that have other roles. If you want to install Veeam Data Movers on such servers, open the Edit Linux Server wizard for the necessary server and click Finish.

     

    Requirements and Limitations for Veeam Data Movers

    Before you use Veeam Data Movers, consider the following requirements and limitations for Linux and Microsoft Windows servers:

    • Linux server version must be 64-bit. For more information, see System Requirements. Note that Perl is required only for non-persistent Veeam Data Movers. Check the full list of required Perl modules in this Veeam KB article.
    • Veeam Backup & Replication does not deploy Veeam Data Movers on deduplicating storage appliances based on Linux.
    • If you want to use persistent Veeam Data Movers, the user account specified for the server must have root or elevated to root permission. Otherwise, Veeam Data Movers will be non-persistent, that is, the Linux server will not host Veeam Data Movers permanently.
    • When you add a Linux server using single-use credentials, the user account must still have elevated to root permission in order for Veeam Data Movers to be persistent.
    • For Microsoft Hyper-V and Microsoft Windows servers: file and printer sharing must be enabled in network connection settings of the added server.

    Tip

    If Veeam Data Mover on a Linux server fails for some reason, you can re-install it manually. For more information, see this Veeam KB article.